» Details |
---|
» Comment |
Take care of these and I'm happy: * Returning a value immediately after throwing an exception is redundant - that code won't get executed so don't include it in the first place. * I'd subclass Exception to Services_Mailman_Exception. * There's inconsistent use/lack of use of whitespace; eg. 'send_unsub_ack_to_this_batch'=>0 versus 'send_welcome_msg_to_this_batch' => 0 * You don't need to prepend the method name to the exception message - the method name isn't going to change so I'd hardcode it and avoid using the __METHOD__ magic constant and concatenation. |